7

Syntax highlighting does not work when adding code blocks (Like StackOverflow)
See this answer for an example.

It works here in meta though -@phwd

| | | | | |
  • 1
    Works: SO, MSO, MWA, PW, MPW, Doesn't work: WA, FC, MFC, A, MA, PR, MPR – Rebecca Chernoff Oct 5 '10 at 17:55
  • 1
    @rchern: But why? – chanchal1987 Oct 5 '10 at 18:57
  • 1
    I don't know. Seems like something the team will need to look at. I was just trying to provide further detail. – Rebecca Chernoff Oct 5 '10 at 18:57
-1

It is explicitly disabled. It should be disabled on meta as well.

We don't feel code highlighting is needed on web apps -- preformatted text is all that is intended, and auto-syntax would be a negative, like so:

this is a table

item1   item2
-----   -----
3       a
4       b
5       c
| | | | | |
  • 1
    That makes sense, but perhaps there could be special cases? For instance if a preformatted text block starts with a shebang. I'm personally interested as I'm active on askubuntu. While I can imagine many times where auto-syntax would be a negative there, there is also the need to post scripts as well. – andrewsomething Oct 15 '10 at 19:07
0

Seems to be working in meta.

import flash.display.MovieClip;

public class SimpleFlash extends MovieClip {
    public function SimpleFlash() {

    }
}

dp.SyntaxHighlighter.BloggerMode();
dp.SyntaxHighlighter.HighlightAll('code');
| | | | | |
  • 2
    It doesn't now. – user79865 Jul 19 '15 at 22:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .